Wersje językowe w WordPress. Polylang – od tego zaczynaj!

Jeżeli twoja strona ma być wielo­ję­zy­ko­wa, to od razu należy zainsta­lo­wać wtycz­kę obsłu­gi wersji języko­wych. Warto pomyśleć o tym nawet jeżeli nie planu­jesz jeszcze rozbu­do­wy. Klient za chwilę się namyśli i zaczną się proble­my. Dlacze­go to takie ważne? Bo żeby wersje języko­we działa­ły, trzeba dodać oznacze­nie języka do adresu url, co zmienia struk­tu­rę pozio­mów. Jeżeli w css stosu­jesz linki bez http://, ale nacelo­wa­ne na konkret­ny zasób, to po wprowa­dze­niu zmian w adresie przybę­dzie ci jeden poziom i wszędzie trzeba będzie albo dodać nazwę języka albo wstawić dodat­ko­we przej­ście na poziom wyżej '../​'. Najlep­szym rozwią­za­niem wydaje się być wtycz­ka 'Polylang'

Czytaj więcej

Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /home/arporo/public_html/prostykod.pl/wp-includes/functions.php on line 5219